iHealth Acacia Blood Glucose Monitor Kit (Model AG-607)
Box Contents
- Blood Glucose Meter (AG-607)
- 2x AAA Batteries
- Test Strips (2x EGS-2003)
- Lancing Device
- 100 Lancets
- Instruction Manual
- Carrying Bag
Technical Characteristics
- Model: iHealth Acacia AG-607
- Dimensions: 4.3” x 2.05” x 0.81”
- Screen: LED
- Measuring Method: Amperometric technology using glucose dehydrogenase
- Measuring Range: 20-600 mg/dL (1.1-33.3 mmol/L)
- Power Source: 2 x 1.5V AAA batteries
- Storage Conditions (Test Strips): 4°C ~ 30°C (30°F ~ 86°F) and 10% ~ 85% RH
- Storage Conditions (Meter): -20°C ~ 55°C (-4°F ~ 131°F) and 10% ~ 80% RH
- Operating Conditions: 10°C ~ 40°C (50°F ~ 104°F) and 25% ~ 80% RH
- Blood Source: Fresh capillary whole blood
- Blood Volume: 0.7 µL minimum
- Lifespan: 5 years
iHealth Acacia AG-607 - List of Error Messages
Lo: Blood glucose level is lower than 20 mg/dl (1.1 mmol/L). The message indicates very low blood glucose. Consult your healthcare professional.
H1: Blood glucose level is higher than 600 mg/dl (33.3 mmol/L). The message indicates severe hyperglycemia (high blood glucose). Seek immediate medical assistance.
EE1: The batteries in your meter are low on power. Please change the batteries.
EE2: Problem with the meter. Retest using a new test strip.
EE3: Problems have occurred that are related to test strip use. Please retest using a new test strip.
- The test strip may be wet or damaged.
- The test strip may have been removed too early.
- You applied more blood after testing began.
EE4: Problem with the meter. Please retest using a new test strip.
EE5: The environmental temperature is lower than 10°C (50°F). The operating temperature is 10°C ~ 40°C (50°F ~ 104°F).
EE6: The environmental temperature is higher than 40°C (104°F). The operating temperature is 10°C ~ 40°C (50°F ~ 104°F).
EEA: Problem with the meter. Retest with a new test strip. If the problem persists, contact Customer Service.
EEB: Problem with the meter. Retest with a new test strip. If the problem persists, contact Customer Service.
Troubleshooting
- Display remains blank after inserting the test strip:
- Possible Causes:
- Battery power is too low.
- Too much time has passed between inserting the strip and performing the test.
- Test strip not fully inserted.
- Solutions:
- Change the batteries.
- Reinsert the test strip correctly.
- Ensure the test strip is properly inserted.
- Possible Causes:
- Inconsistent test results or control solution test results out of range:
- Possible Causes:
- Insufficient blood sample.
- Expired or damaged test strips.
- The test strip has been damaged due to heat or humidity, so that the sample cannot be applied, or the speed of application is too slow.
- The system is not performing due to the environment being above or below room temperature.
- Solutions:
- Retest with a new strip and ensure there is enough blood sample.
- Use a new test strip or control solution to retest accuracy
- Perform a control solution test using a new strip. If results are still out of range, replace with the new vial of test strips.
- Bring the meter and strips to a room temperature environment and wait approximately 30 minutes before performing a new test.
- Possible Causes:
- Meter countdown did not start:
- Possible Cause: Incorrect insertion of the test strip.
- Solution: Insert a new test strip and retest.