Common issues and solutions
Measurement Inaccuracy
Category 1: Measurement Inaccuracy - High Readings
Causes:
- Improper cuff placement;
- Incorrect measurement method;
- Talking or moving the arm during measurement;
- Other hardware malfunctions.
Solutions:
Remeasure following these steps:
- Cuff Size: Ensure the cuff size provided with the product is appropriate.
- Cuff Placement: For the left arm, follow the direction shown in the promotional image. For the right arm, refer to the instructions. Place the cuff on a bare arm or over thin clothing. Ensure it fits snugly, allowing just enough space to insert one finger.
- Before Measurement: Rest in a comfortable environment for 5 minutes to stabilize your body state. Keep the cuff at the same level as your heart; a lower position may result in higher readings.
- During Measurement: Remain quiet and still, avoiding talking or moving.
Category 2: Measurement Inaccuracy - Unstable Values
Causes:
- Improper cuff placement;
- Incorrect measurement method;
- Talking or moving the arm during measurement;
- Other hardware malfunctions.
Solutions:
Remeasure following these steps:
- Cuff Size: Ensure the cuff size provided with the product is appropriate.
- Cuff Placement: For the left arm, follow the direction shown in the promotional image. For the right arm, refer to the instructions. Place the cuff on a bare arm or over thin clothing. Ensure it fits snugly, allowing just enough space to insert one finger.
- Before Measurement: Rest in a comfortable environment for 5 minutes to stabilize your body state. Use the same arm and posture for each measurement, and keep the cuff at the same level as your heart.
- During Measurement: Remain quiet and still, avoiding talking or moving.
Cuff Issues
Category 1: Cuff Too Large
Causes:
- Cuff is too loose;
- Arm circumference is too small compared to the cuff size.
Solutions:
- After wearing the cuff properly, check if the arrow on the cuff is within the usable range. If the usable range is to the right of the arrow, the cuff is too small.
Category 2: Cuff Too Small
Causes:
- Cuff is too tight;
- Arm circumference is too large compared to the cuff size;
Solutions:
- Confirm that the you have correctly placed the cuff. If the Vecro does not hold properly or detaches during inflation after being barely stuck, purchase a larger cuff.
- 22-42cm Cuff Judgment Method:
- After wearing the cuff properly, check if the highlighted area shows the arrow. If the arrow is not visible, the cuff is too small. If the arrow is visible, the cuff is suitable.
- If the arrow is not visible, measure your arm circumference (at the midpoint where the cuff is worn). If it is within the 22-42cm range, the cuff can still be used even if the arrow is not visible. If it exceeds this range, it is not recommended to use it.
- 22-36cm, 30-42cm, 42-48cm Cuff Judgment Method:
- After wearing the cuff properly, check the highlighted area and the arrow's indication range. If the indication range exceeds the usable range, the cuff is too small. If it does not exceed, the cuff is suitable.
- If the indication range has exceeded the usable range, measure your arm circumference (at the midpoint where the cuff is worn).If it is within the usable range, the arrow's indication range can be ignored.
Category 3: Cuff Discomfort or Pain
Causes:
- Prolonged or repeated measurements;
Solutions:
- Rebind the cuff, ensuring it is smooth during the process and remain still during measurement. If there is no improvement, contact customer service at support@ihealthlabs.com for a possible return or replacement .
Host Function Malfunctions
Category 1: Device Does Not Turn On
Causes:
- Incorrectly installed batteries;
- External factors such as water ingress or dropping;
- Other hardware malfunctions;
Solutions:
- Check to verify that the batteries are correctly installed.
- Contact customer service at support@ihealthlabs.com for a possible return or replacement.
Category 2: Battery Drains Quickly
Causes:
- Use of alkaline or rechargeable batteries;
- External factors such as water ingress or dropping;
- Other hardware malfunctions;
Solutions:
- Replace with alkaline batteries.
- Contact customer service at support@ihealthlabs.com for a possible return or replacement.
Category 3: Device Does Not Inflate, Pump Not Working
Causes:
- Air leakage in the pneumatic system or the cuff is too loose during inflation;
Solutions:
- Reinsert the air tube and measure again.
- Rebind the cuff, ensuring it fits snugly against the arm and remain still during measurement.
- Contact customer service at support@ihealthlabs.com for a possible return or replacement.
Category 4: Screen Malfunction (Half display, missing segments, faint display, abnormal screen color)
Causes:
- External factors such as water ingress or dropping;
- Other hardware malfunctions;
Solutions:
- The optimal viewing angle for the screen is 45 degrees, not 90 degrees.
- Contact customer service at support@ihealthlabs.com for a possible return or replacement.
Product Appears To Have Been Previously Used
Category 1: Amazon Resale
Causes:
Amazon's sales policy allows resale of unopened products within 7 days. Amazon confuses returned products with resold products.
Solutions:
Contact Amazon for a return.